re = /\.(?=\.|$)|[^0-9.\n]/m
str = '1...2.3.
1.2.3...
.....
1.1.1.1
1.441.13443.134434'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result