const regex = /\.(?=\.|$)|[^0-9.\n]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?=\\.|$)|[^0-9.\\n]', 'gm')
const str = `1...2.3.
1.2.3...
.....
1.1.1.1
1.441.13443.134434`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);