using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<iframe[^>]*?title=(\\\'|\\""|[\'""])([^>]*?)\1";
string input = @"<img src=""..."" title=""title""/>
'<iframe src=""..."" title=""title"" width=""324"" height=""auto""/>'
""<iframe src='...' width='324' height='auto' title='title' ></iframe>""
""<iframe src=\""...\"" title=\""title\"" width=\""324\"" height=\""auto\""/>""
'<iframe src=\'...\' width=\'324\' height=\'auto\' title=\'title\' ></iframe>'
""<iframe src=\""...\"" title=\""title's with apostrophe\"" width=\""324\"" height=\""auto\""/>""
""<iframe src='...' width='324' height='auto' title='title \""quoting\"" something' ></iframe>""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}