import re
regex = re.compile(r"<iframe[^>]*?title=(\\\'|\\\"|[\'\"])([^>]*?)\1", flags=re.MULTILINE)
test_str = ("<img src=\"...\" title=\"title\"/>\n"
"'<iframe src=\"...\" title=\"title\" width=\"324\" height=\"auto\"/>'\n"
"\"<iframe src='...' width='324' height='auto' title='title' ></iframe>\"\n"
"\"<iframe src=\\\"...\\\" title=\\\"title\\\" width=\\\"324\\\" height=\\\"auto\\\"/>\"\n"
"'<iframe src=\\'...\\' width=\\'324\\' height=\\'auto\\' title=\\'title\\' ></iframe>'\n"
"\"<iframe src=\\\"...\\\" title=\\\"title's with apostrophe\\\" width=\\\"324\\\" height=\\\"auto\\\"/>\"\n"
"\"<iframe src='...' width='324' height='auto' title='title \\\"quoting\\\" something' ></iframe>\"\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")