const regex = /<iframe[^>]*?title=(\\\'|\\"|[\'"])([^>]*?)\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<iframe[^>]*?title=(\\\\\\\'|\\\\"|[\\\'"])([^>]*?)\\1', 'gm')
const str = `<img src="..." title="title"/>
'<iframe src="..." title="title" width="324" height="auto"/>'
"<iframe src='...' width='324' height='auto' title='title' ></iframe>"
"<iframe src=\\"...\\" title=\\"title\\" width=\\"324\\" height=\\"auto\\"/>"
'<iframe src=\\'...\\' width=\\'324\\' height=\\'auto\\' title=\\'title\\' ></iframe>'
"<iframe src=\\"...\\" title=\\"title's with apostrophe\\" width=\\"324\\" height=\\"auto\\"/>"
"<iframe src='...' width='324' height='auto' title='title \\"quoting\\" something' ></iframe>"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}