# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b|[#])ИС-5 B\\/1 D\.06' \(Объект 730\)(?=\b|[^-])/#ИС_5_Объект_730/uig;t' <<< "ИС-5 B/1 D.06' (Объект 730)
ИС-5 B/1 Dd06' (Объект 730)
ИС-5 B/1 D!06' (Объект 730)
ИС-5 B/1 D_06' (Объект 730)
#ИС-5 B/1 D.06' (Объект 730)
ИС-5 B/1 D(06' (Объект 730)
ИС-5 B/1 D\"06' (Объект 730)"