import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"(\b|[#])ИС-5 B\/1 D\.06' \(Объект 730\)(?=\b|[^-])"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
ИС-5 B/1 D.06' (Объект 730)
ИС-5 B/1 Dd06' (Объект 730)
ИС-5 B/1 D!06' (Объект 730)
ИС-5 B/1 D_06' (Объект 730)
#ИС-5 B/1 D.06' (Объект 730)
ИС-5 B/1 D(06' (Объект 730)
ИС-5 B/1 D"06' (Объект 730)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#ИС_5_Объект_730"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)