re = /(\b|[#])ИС-5 B\/1 D\.06' \(Объект 730\)(?=\b|[^-])/i
str = 'ИС-5 B/1 D.06\' (Объект 730)
ИС-5 B/1 Dd06\' (Объект 730)
ИС-5 B/1 D!06\' (Объект 730)
ИС-5 B/1 D_06\' (Объект 730)
#ИС-5 B/1 D.06\' (Объект 730)
ИС-5 B/1 D(06\' (Объект 730)
ИС-5 B/1 D"06\' (Объект 730)'
subst = '#ИС_5_Объект_730'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result