#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ui)(\b|[#])ИС-5 B\/1 D\.06' \(Объект 730\)(?=\b|[^-])"
Local $sString = "ИС-5 B/1 D.06' (Объект 730)" & @CRLF & _
"ИС-5 B/1 Dd06' (Объект 730) " & @CRLF & _
"ИС-5 B/1 D!06' (Объект 730)" & @CRLF & _
"ИС-5 B/1 D_06' (Объект 730) " & @CRLF & _
"#ИС-5 B/1 D.06' (Объект 730)" & @CRLF & _
"ИС-5 B/1 D(06' (Объект 730) " & @CRLF & _
"ИС-5 B/1 D"06' (Объект 730)"
Local $sSubst = "#ИС_5_Объект_730"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)