using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\/[^\r\n]*";
string input = @"Sample of text line 1
Sample of text line 2 // to be removed, including the double slashes
Sample of text line 3//
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}