$re = '/\/\/[^\r\n]*/';
$str = 'Sample of text line 1
Sample of text line 2 // to be removed, including the double slashes
Sample of text line 3//
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);