// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/\/[^\r\n]*").unwrap();
let string = "Sample of text line 1
Sample of text line 2 // to be removed, including the double slashes
Sample of text line 3//
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}