package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/\/[^\r\n]*`)
var str = `Sample of text line 1
Sample of text line 2 // to be removed, including the double slashes
Sample of text line 3//
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}