re = /\/\/[^\r\n]*/
str = 'Sample of text line 1
Sample of text line 2 // to be removed, including the double slashes
Sample of text line 3//
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end