const regex = /\/\/[^\r\n]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\\/[^\\r\\n]*', 'g')
const str = `Sample of text line 1
Sample of text line 2 // to be removed, including the double slashes
Sample of text line 3//
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}