using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(rgba\(.*?\))";
string input = @"const str = ""linear-gradient(90deg, rgba(243,231,231,1), rgba(12,0,0,0.48))""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}