// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(rgba\(.*?\))").unwrap();
let string = "const str = \"linear-gradient(90deg, rgba(243,231,231,1), rgba(12,0,0,0.48))\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}