const regex = /(rgba\(.*?\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(rgba\\(.*?\\))', 'gm')
const str = `const str = "linear-gradient(90deg, rgba(243,231,231,1), rgba(12,0,0,0.48))"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}