$re = '/(rgba\(.*?\))/m';
$str = 'const str = "linear-gradient(90deg, rgba(243,231,231,1), rgba(12,0,0,0.48))"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);