re = /(rgba\(.*?\))/m
str = 'const str = "linear-gradient(90deg, rgba(243,231,231,1), rgba(12,0,0,0.48))"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end