#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+[0-2]{1}[0-9]{1}[0-2]{1}[0-5]{1}$"
Local $sString = "+0163" & @CRLF & _
"+0125" & @CRLF & _
"+022529" & @CRLF & _
"d1234" & @CRLF & _
"D1234" & @CRLF & _
"D123" & @CRLF & _
"p1234" & @CRLF & _
"+01" & @CRLF & _
"" & @CRLF & _
"+2115" & @CRLF & _
"" & @CRLF & _
"+0000" & @CRLF & _
"+0105" & @CRLF & _
"+2528" & @CRLF & _
"" & @CRLF & _
"00+" & @CRLF & _
"01+" & @CRLF & _
"11+" & @CRLF & _
"25+" & @CRLF & _
"26+" & @CRLF & _
"27+" & @CRLF & _
"01+24+03+04+" & @CRLF & _
"15" & @CRLF & _
"01" & @CRLF & _
"11" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")