use strict;
my $str = '+0163
+0125
+022529
d1234
D1234
D123
p1234
+01
+2115
+0000
+0105
+2528
00+
01+
11+
25+
26+
27+
01+24+03+04+
15
01
11
1
2
3
4';
my $regex = qr/^\+[0-2]{1}[0-9]{1}[0-2]{1}[0-5]{1}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}