re = /^\+[0-2]{1}[0-9]{1}[0-2]{1}[0-5]{1}$/m
str = '+0163
+0125
+022529
d1234
D1234
D123
p1234
+01
+2115
+0000
+0105
+2528
00+
01+
11+
25+
26+
27+
01+24+03+04+
15
01
11
1
2
3
4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end