import Foundation
let pattern = #"^\+[0-2]{1}[0-9]{1}[0-2]{1}[0-5]{1}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+0163
+0125
+022529
d1234
D1234
D123
p1234
+01
+2115
+0000
+0105
+2528
00+
01+
11+
25+
26+
27+
01+24+03+04+
15
01
11
1
2
3
4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)