using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+[0-2]{1}[0-9]{1}[0-2]{1}[0-5]{1}$";
string input = @"+0163
+0125
+022529
d1234
D1234
D123
p1234
+01
+2115
+0000
+0105
+2528
00+
01+
11+
25+
26+
27+
01+24+03+04+
15
01
11
1
2
3
4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}