import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+[0-2]{1}[0-9]{1}[0-2]{1}[0-5]{1}$";
final String string = "+0163\n"
+ "+0125\n"
+ "+022529\n"
+ "d1234\n"
+ "D1234\n"
+ "D123\n"
+ "p1234\n"
+ "+01\n\n"
+ "+2115\n\n"
+ "+0000\n"
+ "+0105\n"
+ "+2528\n\n"
+ "00+\n"
+ "01+\n"
+ "11+\n"
+ "25+\n"
+ "26+\n"
+ "27+\n"
+ "01+24+03+04+\n"
+ "15\n"
+ "01\n"
+ "11\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}