# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z])\1\1\1+/$1$1$1/gi;t' <<< "fahuo aaaa dislgjsd oooodfuabfaaaaaagdggs iiiii
AAAAAAAA BBBBBBBB hhfasfuahaaaaaHHHHHHH OOOHHHHHHHH"