import Foundation
let pattern = #"([a-z])\1\1\1+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
fahuo aaaa dislgjsd oooodfuabfaaaaaagdggs iiiii
AAAAAAAA BBBBBBBB hhfasfuahaaaaaHHHHHHH OOOHHHHHHHH
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$1$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)