use strict;
my $str = 'fahuo aaaa dislgjsd oooodfuabfaaaaaagdggs iiiii
AAAAAAAA BBBBBBBB hhfasfuahaaaaaHHHHHHH OOOHHHHHHHH';
my $regex = qr/([a-z])\1\1\1+/ip;
my $subst = '$1$1$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";