#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)([a-z])\1\1\1+"
Local $sString = "fahuo aaaa dislgjsd oooodfuabfaaaaaagdggs iiiii " & @CRLF & _
"AAAAAAAA BBBBBBBB hhfasfuahaaaaaHHHHHHH OOOHHHHHHHH"
Local $sSubst = "$1$1$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)