const regex = /([a-z])\1\1\1+/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z])\\1\\1\\1+', 'gi')
const str = `fahuo aaaa dislgjsd oooodfuabfaaaaaagdggs iiiii
AAAAAAAA BBBBBBBB hhfasfuahaaaaaHHHHHHH OOOHHHHHHHH`;
const subst = `$1$1$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);