re = /([a-z])\1\1\1+/i
str = 'fahuo aaaa dislgjsd oooodfuabfaaaaaagdggs iiiii
AAAAAAAA BBBBBBBB hhfasfuahaaaaaHHHHHHH OOOHHHHHHHH'
subst = '$1$1$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result