using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";(?<VCX_NODE>\w{3,4}#\d)\s*\w\s\d\s\d\s\w{3}\s-\s(?<mfctrunk>.*)\/(?<mfcline>.*)\((?<mfclineslot>\d{1,3})\)";
string input = @"VCX_Stat;30.09.2018 22:58:37;S;LNZ#1 V 1 0 LNZ - VIE___2MBit__/lnzvie1201(8):656825->663625 Voc ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}