import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ";(?<VCX_NODE>\\w{3,4}#\\d)\\s*\\w\\s\\d\\s\\d\\s\\w{3}\\s-\\s(?<mfctrunk>.*)\\/(?<mfcline>.*)\\((?<mfclineslot>\\d{1,3})\\)";
final String string = "VCX_Stat;30.09.2018 22:58:37;S;LNZ#1 V 1 0 LNZ - VIE___2MBit__/lnzvie1201(8):656825->663625 Voc ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}