#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?!.*(?:_dev|_pre|_prod|_test|_)$)[\w-]{1,64}$"
Local $sString = "!min0db_dev1" & @CRLF & _
"min0db_dev_dev" & @CRLF & _
"min0db_" & @CRLF & _
"_dev" & @CRLF & _
"_" & @CRLF & _
"min0db_dev1" & @CRLF & _
"min0db" & @CRLF & _
"min0_devdb" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")