const regex = /(?i)^(?!.*(?:_dev|_pre|_prod|_test|_)$)[\w-]{1,64}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)^(?!.*(?:_dev|_pre|_prod|_test|_)$)[\\w-]{1,64}$', 'gm')
const str = `!min0db_dev1
min0db_dev_dev
min0db_
_dev
_
min0db_dev1
min0db
min0_devdb
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}