import re
regex = re.compile(r"(?i)^(?!.*(?:_dev|_pre|_prod|_test|_)$)[\w-]{1,64}$", flags=re.MULTILINE)
test_str = ("!min0db_dev1\n"
"min0db_dev_dev\n"
"min0db_\n"
"_dev\n"
"_\n"
"min0db_dev1\n"
"min0db\n"
"min0_devdb\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")