re = /(?i)^(?!.*(?:_dev|_pre|_prod|_test|_)$)[\w-]{1,64}$/m
str = '!min0db_dev1
min0db_dev_dev
min0db_
_dev
_
min0db_dev1
min0db
min0_devdb
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end