const regex = /(.*)\\u0026(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\\\u0026(.*)', 'gm')
const str = `http://drive.google.com/uc?export=view\\u0026id=1mbR99z1qdjlR3s3YgM3uPT0S-fRNeUS-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}