// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\\u0026(.*)").unwrap();
let string = "http://drive.google.com/uc?export=view\\u0026id=1mbR99z1qdjlR3s3YgM3uPT0S-fRNeUS-";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}