$re = '/(.*)\\\\u0026(.*)/m';
$str = 'http://drive.google.com/uc?export=view\\u0026id=1mbR99z1qdjlR3s3YgM3uPT0S-fRNeUS-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);