package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0x[a-fA-F0-9]{1,40}$`)
var str = `0xc1e5017fbc68aa3e56aa580708de9aa123d62d18!
0xc1e5017fbc68aa3e56aa580708de9aa123d62d18`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}