const regex = /^0x[a-fA-F0-9]{1,40}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0x[a-fA-F0-9]{1,40}$', 'gm')
const str = `0xc1e5017fbc68aa3e56aa580708de9aa123d62d18!
0xc1e5017fbc68aa3e56aa580708de9aa123d62d18`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}