import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0x[a-fA-F0-9]{1,40}$";
final String string = "0xc1e5017fbc68aa3e56aa580708de9aa123d62d18!\n"
+ "0xc1e5017fbc68aa3e56aa580708de9aa123d62d18";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}