#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/blog\/post\?id=)([\w\d]*)&(?:\w*.*)(&id\d)(=\d)"
Local $sString = "/blog/post?id=34331824c1866ffb&extraParam=23232&id2=2" & @CRLF & _
"" & @CRLF & _
"/blog/post?id=343fb434343&extraParam=XXXX&id2=2" & @CRLF & _
"" & @CRLF & _
"/blog/post?id=34331824c1866ffb&id2=2" & @CRLF & _
"" & @CRLF & _
"/blog/post?id=343fb434343&id2=2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")