import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/blog\\/post\\?id=)([\\w\\d]*)&(?:\\w*.*)(&id\\d)(=\\d)";
final String string = "/blog/post?id=34331824c1866ffb&extraParam=23232&id2=2\n\n"
+ "/blog/post?id=343fb434343&extraParam=XXXX&id2=2\n\n"
+ "/blog/post?id=34331824c1866ffb&id2=2\n\n"
+ "/blog/post?id=343fb434343&id2=2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}