package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/blog\/post\?id=)([\w\d]*)&(?:\w*.*)(&id\d)(=\d)`)
var str = `/blog/post?id=34331824c1866ffb&extraParam=23232&id2=2
/blog/post?id=343fb434343&extraParam=XXXX&id2=2
/blog/post?id=34331824c1866ffb&id2=2
/blog/post?id=343fb434343&id2=2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}