// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/blog\/post\?id=)([\w\d]*)&(?:\w*.*)(&id\d)(=\d)").unwrap();
let string = "/blog/post?id=34331824c1866ffb&extraParam=23232&id2=2
/blog/post?id=343fb434343&extraParam=XXXX&id2=2
/blog/post?id=34331824c1866ffb&id2=2
/blog/post?id=343fb434343&id2=2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}