re = /(\/blog\/post\?id=)([\w\d]*)&(?:\w*.*)(&id\d)(=\d)/m
str = '/blog/post?id=34331824c1866ffb&extraParam=23232&id2=2
/blog/post?id=343fb434343&extraParam=XXXX&id2=2
/blog/post?id=34331824c1866ffb&id2=2
/blog/post?id=343fb434343&id2=2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end