const regex = /(\/blog\/post\?id=)([\w\d]*)&(?:\w*.*)(&id\d)(=\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/blog\\\/post\\?id=)([\\w\\d]*)&(?:\\w*.*)(&id\\d)(=\\d)', 'gm')
const str = `/blog/post?id=34331824c1866ffb&extraParam=23232&id2=2
/blog/post?id=343fb434343&extraParam=XXXX&id2=2
/blog/post?id=34331824c1866ffb&id2=2
/blog/post?id=343fb434343&id2=2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}